Can I install the LIQUID app on an older phone?

The LIQUID app should work on iPhones at least from model 6 onwards. There is a good chance that it will work well on older models also, but it wasn’t tested as thoroughly. We also tested various Android devices.

If you encounter issues installing LIQUID on your phone, please contact support@ngrave.io

Was this article helpful?
0 out of 0 found this helpful